Login Problems
Incident Report for Atera
Resolved
This incident has been resolved
Posted Nov 11, 2017 - 14:32 EST
Investigating
Some customers in our EU DC may experience login issues due to a problem in our Azure Infrastructure. For more details check here : https://azure.microsoft.com/en-us/status/
Posted Nov 11, 2017 - 13:46 EST