Splashtop Scheduled Maintenance announcement
Incident Report for Atera
Resolved
The scheduled maintenance has been completed.
Posted 11 months ago. Nov 04, 2018 - 10:27 UTC
Monitoring
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 11 months ago. Nov 04, 2018 - 09:09 UTC
This incident affected: Remote Control.