Intermediate login issues due to problem with MS azure.
Incident Report for Atera
Resolved
This incident has been resolved.
Posted 3 months ago. May 03, 2019 - 03:28 UTC
Identified
Some of our customers may experience slow login times due to a global problem with MS Azure. Our teams are monitoring the situation closely and we will update as soon as possible. We're sorry for the inconvenience caused.
https://azure.microsoft.com/en-us/status/
Posted 3 months ago. May 02, 2019 - 20:58 UTC
This incident affected: Admin Console GUI, Remote Control, and API Service.