Degraded performance for EU customers
Incident Report for Atera
Resolved
A fix has been applied to solve the issue.
Posted 2 months ago. May 14, 2019 - 14:33 UTC
Identified
Some of customers in Europe may encounter slowness in the tickets and devices tabs. Our DevOps engineers identified the issue and working to get it resolved ASAP.
Posted 2 months ago. May 14, 2019 - 13:39 UTC
This incident affected: Admin Console GUI.