Cloudflare Outage Impacting Services

Incident Report for Atera

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 17:53 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2025 - 17:32 EDT

Investigating

We are currently experiencing service disruptions due to a widespread outage affecting Cloudflare.

Our engineers are actively monitoring the situation and exploring mitigation steps to minimize the impact on our services. We will provide updates as more information becomes available.
Posted Jun 12, 2025 - 14:56 EDT
This incident affected: RMM Services (Main Dashboard).