Splashtop Connectivity Issues
Incident Report for Atera
Resolved
This incident has been resolved.
Posted 26 days ago. Jul 25, 2019 - 15:28 UTC
Update
The issue seems to be resolved now, we're checking with our partners in Splashtop what caused this service interruption.
Posted 26 days ago. Jul 25, 2019 - 15:22 UTC
Investigating
We have received some reports from customers that they are experiencing problems connecting to devices. We are on it and will update ASAP!
Posted 26 days ago. Jul 25, 2019 - 14:33 UTC
This incident affected: Remote Control.