Degraded Performance in EU Region
Incident Report for Atera
Resolved
This incident has been resolved, no further actions required.
Posted May 07, 2020 - 10:29 UTC
Monitoring
A fix has been implemented and we're monitoring the results.
Posted May 07, 2020 - 10:18 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 07, 2020 - 09:53 UTC
This incident affected: Admin Console GUI.