Stability issues for EU & UK regions

Incident Report for Atera

Resolved

This incident has been resolved.
Posted Jan 12, 2026 - 10:08 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 12, 2026 - 09:28 EST

Identified

Customers in the EU & UK regions may experience login issues, slowness, and difficulties performing actions within the Atera console.

Our teams are actively working to resolve this issue and restore normal service as soon as possible.
Posted Jan 12, 2026 - 06:48 EST
This incident affected: Admin Console GUI.