Degraded Performance for Ticket Conversations

Incident Report for Atera

Resolved

This incident has been resolved
Posted Jun 22, 2026 - 03:21 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2026 - 00:14 EDT

Investigating

We are aware of an issue affecting the Ticket Conversations tab. Some users may experience a blank view or be unable to send replies. Our team is actively investigating and working to restore full functionality as quickly as possible.
Posted Jun 22, 2026 - 00:10 EDT
This incident affected: PSA Services (Helpdesk).