Admin Console GUI - Maintenance announcement (US region)
Incident Report for Atera
Resolved
The maintenance has been completed.
Posted 5 months ago. Dec 19, 2018 - 11:06 UTC
Monitoring
Maintenance is currently in progress. We will provide updates as necessary.
Posted 5 months ago. Dec 19, 2018 - 10:45 UTC
This incident affected: Admin Console GUI.