Splashtop Performance
Incident Report for Atera
Resolved
This incident has been resolved.
Posted Nov 28, 2024 - 07:17 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 28, 2024 - 06:41 EST
Investigating
We are currently experiencing connectivity issues with Splashtop services in Europe. Our team is actively working to resolve the issue as quickly as possible. We appreciate your patience and understanding.
Posted Nov 28, 2024 - 06:19 EST
This incident affected: Remote Control.