Website down
Incident Report for Atera
Resolved
Website back up and available.
Posted Aug 18, 2019 - 21:11 UTC
Identified
Some customers may experience issues reaching www.atera.com . If you need to login, please do so via https://app.atera.com/Login
Posted Aug 18, 2019 - 17:20 UTC