Degraded / Slow GUI performance
Incident Report for Atera
Resolved
This incident has been resolved.
Posted Oct 30, 2023 - 17:01 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 30, 2023 - 16:36 EDT
Investigating
Some of our customers are currently facing connectivity issues. Our engineering team is diligently investigating the root causes of the problem and working to restore the service.
Posted Oct 30, 2023 - 16:28 EDT
This incident affected: Admin Console GUI.