Admin Console GUI - Maintenance announcement (EU region)
Incident Report for Atera
Resolved
The maintenance has been completed.
Posted 9 months ago. Dec 22, 2018 - 22:15 UTC
Monitoring
Maintenance is currently in progress. We will provide updates as necessary.
Posted 9 months ago. Dec 22, 2018 - 21:17 UTC
This incident affected: Admin Console GUI.