Atera.com resolution issues
Incident Report for Atera
Resolved
This incident has been resolved.
Posted Jan 25, 2020 - 16:04 UTC
Identified
We identified a DNS issue with that might prevent some of customers reach to www.atera.com . The app is accessible via : https://app.atera.com/login

We're in contacty with our provider to get it resolved ASAP.
Posted Jan 25, 2020 - 15:30 UTC