Customer Portal SSO Login Issue

Incident Report for Atera

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 12:56 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 11, 2025 - 12:46 EDT

Investigating

We are currently experiencing an issue affecting Customer Portal SSO logins. Our team is actively investigating this and working to restore access as quickly as possible. We apologize for the inconvenience and will provide updates as they become available.
Posted Jun 11, 2025 - 12:23 EDT
This incident affected: PSA Services (End User Customer Portal).