There is a DNS issue with Azure.
Incident Report for Atera
Resolved
Issue is resolved.
Posted May 20, 2021 - 08:23 EDT
Investigating
Some customers may experience intermittent log in issues. We're working with our partners at Microsoft to get it resolved as soon as possible.
Posted May 20, 2021 - 03:10 EDT
This incident affected: Admin Console GUI.