Splashtop Service Interruption

Incident Report for Atera

Resolved

This incident has been resolved.
Posted Jan 05, 2026 - 02:47 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 05, 2026 - 02:29 EST

Investigating

Splashtop is currently experiencing a global stack outage. This is impacting our RMM remote access - you may be unable to initiate remote sessions at this time. Their engineering team is investigating.
For real-time status, please monitor: https://status.splashtop.com/
Posted Jan 05, 2026 - 02:22 EST