Website maintenance (www.atera.com)
Incident Report for Atera
Resolved
Maintenance is completed.
Posted Jul 28, 2019 - 16:32 EDT
Monitoring
We will be conducting some site maintenance within the next few hours and our site may experience some downtime during this period. You will be able to log into Atera's platform via app.atera.com. We apologize for any inconvenience this may cause.
Posted Jul 28, 2019 - 14:01 EDT