Login issues for EU & UK regions

Incident Report for Atera

Resolved

This incident has been resolved.
Posted Jan 12, 2026 - 06:38 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 12, 2026 - 05:53 EST

Update

Customers from the EU & UK regions might experience slowness and issues performing actions within the Atera console.

Our teams identified the issue and are deploying a fix.
Posted Jan 12, 2026 - 05:44 EST

Identified

Customers from the EU & UK regions might experience login issues on the Atera console.

Our teams are actively working to resolve this issue and restore normal service as soon as possible.
Posted Jan 12, 2026 - 05:28 EST
This incident affected: Admin Console GUI.