Site Maintenance
Incident Report for Atera
Resolved
This incident has been resolved.
Posted Jun 28, 2020 - 15:29 UTC
Monitoring
Hello Dear Aterans

Due to our marketing site’s maintenance, you might experience irregularity with our marketing website.

You can log in to the Atera dashboard via this link: https://app.atera.com/login

Thank you.
Posted Jun 28, 2020 - 13:31 UTC