Subscription page issues
Incident Report for Atera
Resolved
This incident has been resolved.
Posted May 26, 2020 - 01:05 EDT
Identified
Aterans,

Due to our recent migration into a new Billing module, some customers may experience issues accessing their Subscriptions page.
Please bare with us, we’re working to get the page back up and running soon.
If this is an urgent matter, please contact your Customer Success Manager directly for further assistance.

Thank you!
Posted May 25, 2020 - 10:58 EDT
This incident affected: Admin Console GUI.