Inbound/Outbound email delays
Incident Report for Atera
Resolved
This incident has been resolved.
Posted Nov 27, 2020 - 17:30 EST
Identified
We are currently facing Inbound/Outbound email delays.
Our teams are working on this problem and a hotfix is expected any moment from now on.
Posted Nov 27, 2020 - 11:32 EST