Splashtop Performance

Incident Report for Atera

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 00:54 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 23, 2025 - 00:01 EDT

Investigating

Splashtop servers are currently experiencing an issue. You might not be able to use Splashtop Remote in the console. The engineers are working to resolve it as soon as possible. We apologize for the inconvenience.
Posted Jun 22, 2025 - 20:56 EDT
This incident affected: Remote Control.