Service Disruption Affecting US Customers

Incident Report for Atera

Resolved

The issue has been identified and resolved.
Posted Apr 02, 2026 - 18:50 EDT

Monitoring

The disruption impacting US customers has been fixed. Our team is actively monitoring to confirm full recovery.
Posted Apr 02, 2026 - 17:38 EDT

Update

We are currently experiencing an issue impacting customers in the United States. Our team is investigating and working to restore service as quickly as possible.
Posted Apr 02, 2026 - 17:04 EDT

Investigating

Some clients may experience issues when accessing newly created tickets. Our team is aware and we are actively working towards a resolution.
Posted Apr 02, 2026 - 15:26 EDT
This incident affected: RMM Services (Main Dashboard), PSA Services (Helpdesk), and Admin Console GUI.