Degraded performance and slow login issues
Incident Report for Atera
Resolved
The issue is now resolved.
Posted May 18, 2019 - 15:19 EDT
Investigating
Some of our customer may experience degraded GUI performance and slow logins. Our teams are working to find the root cause of the issue and we'll update as soon as possible.
Posted May 18, 2019 - 15:10 EDT
This incident affected: Admin Console GUI.